Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000634 [ALGLIB] Interpolation minor have not tried 2014-12-01 16:54 2014-12-04 12:04
Reporter SergeyB View Status public  
Assigned To SergeyB
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0000634: FIXED: instability in PolynomialBar2Pow() function
Description Function accumulated rounding errors when magnitude of abscissas was too large or too small (larger or smaller than S - scale parameter). The problem was in the inadequate placement of sampling points - too spread or too close. Now algorithm places sampling points according to spread of nodes of barycentric model, which results in more stable algorithm.
Additional Information
Programming language Unspecified
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2014-12-01 16:54 SergeyB New Issue
2014-12-01 16:54 SergeyB Status new => assigned
2014-12-01 16:54 SergeyB Assigned To => SergeyB
2014-12-01 16:54 SergeyB Programming language => Unspecified
2014-12-04 12:04 SergeyB Summary report by Thermofisher => FIXED: instability in PolynomialBar2Pow() function
2014-12-04 12:04 SergeyB Description Updated
2014-12-04 12:04 SergeyB Status assigned => resolved
2014-12-04 12:04 SergeyB Fixed in Version => Next 'Optimization' release
2014-12-04 12:04 SergeyB Resolution open => fixed

Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker