Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000643 [ALGLIB] Data analysis feature have not tried 2015-01-22 16:01 2015-01-22 16:01
Reporter SergeyB View Status public  
Assigned To SergeyB
Priority normal Resolution implemented  
Status resolved   Product Version
Summary 0000643: IMPLEMENTED: faster k-means clusterization (blocked, parallel)
Description New incarnation of k-means is much faster than previous version due to several improvements:
* initialization algorithm was remastered - we can choose between random initialization, k-means++ (high-quality but slower and non-parallelizable), and "fast-greedy" algorithm which gives reasonably good results while being cache-efficient and parallelizable.
* main k-means iteration is now blocked and parallelized, which significantly improves performance on large-scale datasets
Additional Information
Programming language Unspecified
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2015-01-22 16:01 SergeyB New Issue
2015-01-22 16:01 SergeyB Status new => assigned
2015-01-22 16:01 SergeyB Assigned To => SergeyB
2015-01-22 16:01 SergeyB Programming language => Unspecified
2015-01-22 16:01 SergeyB Status assigned => resolved
2015-01-22 16:01 SergeyB Fixed in Version => Next release
2015-01-22 16:01 SergeyB Resolution open => implemented


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker